Errors affecting billing
Incident Report for GoSquared
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 11:50 BST
Identified
Our payment provider is experiencing issues causing errors in the GoSquared billing system. Some users may experience an error message when upgrading or modifying their GoSquared subscription. If you're having any issues with your GoSquared account, please get in touch!
Posted Sep 23, 2021 - 09:37 BST
This incident affected: User Accounts (Payments and Billing).