Issue with Live Chat and Inbox
Incident Report for GoSquared
Resolved
All services are back to normal.
Posted Aug 31, 2022 - 17:07 BST
Investigating
We're currently investigating an issue that is impacting Live Chat and Inbox. We'll report updates we have them here.
Posted Aug 31, 2022 - 16:35 BST
This incident affected: Live Chat.