Trouble sending email via Chat
Incident Report for GoSquared
Resolved
Email sending via Live Chat is now operating normally.
Posted 12 days ago. Nov 29, 2018 - 18:07 GMT
Investigating
Email sending via Live Chat is currently down. We are looking into it.
Posted 12 days ago. Nov 29, 2018 - 15:13 GMT
This incident affected: Live Chat.