Problems with email delivery from Inbox
Incident Report for GoSquared
Resolved
Email sending from Inbox is now working. Full functionality, including delivery status will return in the next 24 hours. Thanks for your patience while we have worked to resolve these issues.
Posted almost 2 years ago. Nov 28, 2017 - 23:08 GMT
Monitoring
We have corrected a problem with sending emails from Inbox and continue to monitor the situation. Emails are now being delivered successfully.
Posted almost 2 years ago. Nov 28, 2017 - 18:45 GMT
Investigating
We're currently investigating an issue where email delivery is failing for people sending messages via email from Inbox.

We'll update here as soon as we have more information to report.
Posted almost 2 years ago. Nov 28, 2017 - 15:58 GMT